计算长方形的周长和面积(类和对象)

论坛 期权论坛 脚本     
匿名技术用户   2021-1-12 21:17   586   0

计算长方形的周长和面积(类和对象)

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

设计一个长方形类Rect,计算长方形的周长与面积。
成员变量:整型、私有的数据成员length(长)、width(宽);
构造方法如下:
(1)Rect(int length) —— 1个整数表示正方形的边长
(2)Rect(int length, int width)——2个整数分别表示长方形长和宽
成员方法:包含求面积和周长。(可适当添加其他方法)
要求:编写主函数,对Rect类进行测试,输出每个长方形的长、宽、周长和面积。

Input

输入多组数据;
一行中若有1个整数,表示正方形的边长;
一行中若有2个整数(中间用空格间隔),表示长方形的长度、宽度。
若输入数据中有负数,则不表示任何图形,长、宽均为0。

Output

每行测试数据对应一行输出,格式为:(数据之间有1个空格)
长度 宽度 周长 面积

Sample Input

1
2 3
4 5
2
-2
-2 -3

Sample Output

1 1 4 1
2 3 10 6
4 5 18 20
2 2 8 4
0 0 0 0
0 0 0 0
由于不知道输入的数据是一个还是两个,所以我们在读入数据的时候要利用字符串来读取,然后进行字符串的分割取得输入的两个值,
java给我们提供了对应的方法。
package hello;
import java.util.*;
class rect
{
 int length,width;
 rect(int length)
 {
  this.length = length;
  System.out.println(this.length+" "+this.length+" "+4*this.length+" "+this.length*this.length);
 }
 rect(int length,int width)
 {
  this.length = length;
  this.width = width;
  System.out.println(this.length+" "+this.width+" "+2*(this.length+this.width)+" "+this.width*this.length);
 }
 
 }

public class Main {

    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        while(cin.hasNext())
        {
         String s = cin.nextLine();
         char[] a = s.toCharArray();
         int t = 0;
         for(int i=0;i<a.length;i++)
         {
          if(a[i]==' ')
          {
           t = 1;
          }
         }
         if(t==0)
         {
          int c = Integer.parseInt(s);   //将一个String类型字符串转化为数字
          if(c<=0)
           System.out.println("0 0 0 0");
          else 
          {
           rect r1 = new rect(c);
          }
         }
         else
         {
          String s2[] = s.split(" ");   //依据空格进行字符串分割,然后保存在一个String数组中
          int a1 = Integer.parseInt(s2[0]);
          int b1 = Integer.parseInt(s2[1]);
          if(a1<0||b1<0)
          {
           System.out.println("0 0 0 0");
          }
          else
          {
           rect r2 = new rect(a1,b1);
          }
         }
        }
    }
}


分享到 :
0 人收藏
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

积分:7942463
帖子:1588486
精华:0
期权论坛 期权论坛
发布
内容

下载期权论坛手机APP